Sometimes in using a For/Next Loop, I notice that there is just "Next"
and sometimes "Next and (whatever). Is there a difference? TIA
Greg
Sometimes in using a For/Next Loop, I notice that there is just "Next"
and sometimes "Next and (whatever). Is there a difference? TIA
Greg
It's probably good practice to write
for n=1 to 10
do something
next n
but it's exactly the same as
for n=10 to 10:do something:next
Reason for being good practice is
for n=1 to 10
for m = 1 to 10
for o=1 to 10
for p = 1 to 10
next
next
next
next
is harder to read!!! (and to debug - ESPECIALLY if the for next loops
are nested further apart than my example!
Aidan, thanks
Greg
An interesting fact I learned not too long ago:
Sub ABC()
For n = 1 To 10
For m = 1 To 10
For o = 1 To 10
For p = 1 To 10
Debug.Print n, m, o, p
Next p, o, m, n
End Sub
--
Regards,
Tom Ogilvy
"aidan.heritage@virgin.net" wrote:
> It's probably good practice to write
>
> for n=1 to 10
> do something
> next n
>
> but it's exactly the same as
>
> for n=10 to 10:do something:next
>
> Reason for being good practice is
>
> for n=1 to 10
> for m = 1 to 10
> for o=1 to 10
> for p = 1 to 10
> next
> next
> next
> next
>
> is harder to read!!! (and to debug - ESPECIALLY if the for next loops
> are nested further apart than my example!
>
>
Tom, thanks. It is amazing that even you discover some new tidbits.
Thanks for sharing.
Greg
Learned by accident or from a post or somewhere else????
Curious minds want to know <g>.
Tom Ogilvy wrote:
>
> An interesting fact I learned not too long ago:
>
> Sub ABC()
> For n = 1 To 10
> For m = 1 To 10
> For o = 1 To 10
> For p = 1 To 10
> Debug.Print n, m, o, p
> Next p, o, m, n
>
> End Sub
>
> --
> Regards,
> Tom Ogilvy
>
> "aidan.heritage@virgin.net" wrote:
>
> > It's probably good practice to write
> >
> > for n=1 to 10
> > do something
> > next n
> >
> > but it's exactly the same as
> >
> > for n=10 to 10:do something:next
> >
> > Reason for being good practice is
> >
> > for n=1 to 10
> > for m = 1 to 10
> > for o=1 to 10
> > for p = 1 to 10
> > next
> > next
> > next
> > next
> >
> > is harder to read!!! (and to debug - ESPECIALLY if the for next loops
> > are nested further apart than my example!
> >
> >
--
Dave Peterson
From someone else's post. That's why were all really here <g>
--
Regards,
Tom Ogilvy
"Dave Peterson" <petersod@verizonXSPAM.net> wrote in message
news:44776ECE.A9268912@verizonXSPAM.net...
> Learned by accident or from a post or somewhere else????
>
> Curious minds want to know <g>.
>
>
>
> Tom Ogilvy wrote:
> >
> > An interesting fact I learned not too long ago:
> >
> > Sub ABC()
> > For n = 1 To 10
> > For m = 1 To 10
> > For o = 1 To 10
> > For p = 1 To 10
> > Debug.Print n, m, o, p
> > Next p, o, m, n
> >
> > End Sub
> >
> > --
> > Regards,
> > Tom Ogilvy
> >
> > "aidan.heritage@virgin.net" wrote:
> >
> > > It's probably good practice to write
> > >
> > > for n=1 to 10
> > > do something
> > > next n
> > >
> > > but it's exactly the same as
> > >
> > > for n=10 to 10:do something:next
> > >
> > > Reason for being good practice is
> > >
> > > for n=1 to 10
> > > for m = 1 to 10
> > > for o=1 to 10
> > > for p = 1 to 10
> > > next
> > > next
> > > next
> > > next
> > >
> > > is harder to read!!! (and to debug - ESPECIALLY if the for next loops
> > > are nested further apart than my example!
> > >
> > >
>
> --
>
> Dave Peterson
I missed that one. Thanks for sharing.
It kind of looks like something that Tushar would like/do <vbg>.
Tom Ogilvy wrote:
>
> From someone else's post. That's why were all really here <g>
>
> --
> Regards,
> Tom Ogilvy
>
> "Dave Peterson" <petersod@verizonXSPAM.net> wrote in message
> news:44776ECE.A9268912@verizonXSPAM.net...
> > Learned by accident or from a post or somewhere else????
> >
> > Curious minds want to know <g>.
> >
> >
> >
> > Tom Ogilvy wrote:
> > >
> > > An interesting fact I learned not too long ago:
> > >
> > > Sub ABC()
> > > For n = 1 To 10
> > > For m = 1 To 10
> > > For o = 1 To 10
> > > For p = 1 To 10
> > > Debug.Print n, m, o, p
> > > Next p, o, m, n
> > >
> > > End Sub
> > >
> > > --
> > > Regards,
> > > Tom Ogilvy
> > >
> > > "aidan.heritage@virgin.net" wrote:
> > >
> > > > It's probably good practice to write
> > > >
> > > > for n=1 to 10
> > > > do something
> > > > next n
> > > >
> > > > but it's exactly the same as
> > > >
> > > > for n=10 to 10:do something:next
> > > >
> > > > Reason for being good practice is
> > > >
> > > > for n=1 to 10
> > > > for m = 1 to 10
> > > > for o=1 to 10
> > > > for p = 1 to 10
> > > > next
> > > > next
> > > > next
> > > > next
> > > >
> > > > is harder to read!!! (and to debug - ESPECIALLY if the for next loops
> > > > are nested further apart than my example!
> > > >
> > > >
> >
> > --
> >
> > Dave Peterson
--
Dave Peterson
You don't need the control variable in the Next statement.
Next
works exactly the same way as
Next Var
That said, you should always use "Next Var" for documentation
purposes. It make debugging and maintaining code much simpler
when you can see what the Next is refering to, especially in long
procedures.
--
Cordially,
Chip Pearson
Microsoft MVP - Excel
Pearson Software Consulting, LLC
www.cpearson.com
"GregR" <gregrivet@gmail.com> wrote in message
news:1148659385.017693.230330@g10g2000cwb.googlegroups.com...
> Sometimes in using a For/Next Loop, I notice that there is just
> "Next"
> and sometimes "Next and (whatever). Is there a difference? TIA
>
> Greg
>
There are currently 1 users browsing this thread. (0 members and 1 guests)
Bookmarks